<div dir="ltr"><div>Here is the ITK patch to enforce the consistency in the remote module naming:</div><a href="http://review.source.kitware.com/#/c/12444/">http://review.source.kitware.com/#/c/12444/</a><div>This requires the corresponding changes in itk-module.cmake for each of the following remote modules:<br>
<div><div><b>MGHIO, SCIFIIO, SmoothingRecursiveYvvGaussianFilter</b></div><div><br></div><div>So Hans, Mark and I. Vidal, will you mind go ahead and change the module name</div><div>in itk-moduel.cmake please?</div><div><br>
</div><div>I have updated the wiki page and the README file for remote modules:<br></div><div><div><a href="http://www.itk.org/Wiki/ITK/Policy_and_Procedures_for_Adding_Remote_Modules">http://www.itk.org/Wiki/ITK/Policy_and_Procedures_for_Adding_Remote_Modules</a><br>
</div><div><br></div><div>If later we want to implement some cmake hooks to check the name consistency,</div><div>we could do that too.</div><div><br></div><div>Thanks.</div><div><br></div><div>-Xiaoxiao</div><div><br></div>
</div></div></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, Aug 26, 2013 at 11:14 AM, Matt McCormick <span dir="ltr"><<a href="mailto:matt.mccormick@kitware.com" target="_blank">matt.mccormick@kitware.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi Brad and Bill,<br>
<br>
Yes, with the recent simplifications, the ModuleName used in<br>
<br>
itk_fetch_module(ModuleName<br>
<br>
must be the same as the name used in<br>
<br>
itk_module(ModuleName<br>
<br>
Here is an issue to track the topic:<br>
<br>
<a href="https://issues.itk.org/jira/browse/ITK-3203" target="_blank">https://issues.itk.org/jira/browse/ITK-3203</a><br>
<br>
This is a logical expectation, so documenting it may be sufficient.<br>
If the effort required to do a check is reasonably low, that can be<br>
done, too.<br>
<br>
<br>
There are tradeoffs in the Module name policy. If a Remote Module may<br>
someday be fully merged into the ITK repository, then its name will<br>
change, and all the modules that depend on it will need to change the<br>
dependency name. On the other hand, restricting the "ITK" module<br>
namespace to fully merged modules could prevent naming conflicts. I<br>
am not sure which is better.<br>
<br>
Thanks,<br>
Matt<br>
<div class="HOEnZb"><div class="h5"><br>
<br>
On Mon, Aug 26, 2013 at 2:17 PM, Bill Lorensen <<a href="mailto:bill.lorensen@gmail.com">bill.lorensen@gmail.com</a>> wrote:<br>
> I had the same issue with recent changes to Remote modules. I suggest that<br>
> the fetch name and module name be the same. Also, I think Remote module<br>
> names should not have the ITK prefix.<br>
><br>
><br>
><br>
> On Mon, Aug 26, 2013 at 10:07 AM, Bradley Lowekamp <<a href="mailto:blowekamp@mail.nih.gov">blowekamp@mail.nih.gov</a>><br>
> wrote:<br>
>><br>
>> Matt,<br>
>><br>
>> I am trying out some modules as remote instead of External. It appears<br>
>> that turning them on is not as straight forward as I expected. Specifically,<br>
>> when I add a remote cmake file with the following:<br>
>><br>
>> itk_fetch_module(ExternalTemplate<br>
>> "A template for a module."<br>
>> GIT_REPOSITORY <a href="http://github.com/blowekamp/itkExternalTemplate.git" target="_blank">http://github.com/blowekamp/itkExternalTemplate.git</a><br>
>> GIT_TAG master<br>
>> )<br>
>><br>
>><br>
>><br>
>> I have to turn on Module_ExternalTemplate which downloads the module<br>
>> nicely. But the I get the new CMake variable Module_ITKExternalTemplate,<br>
>> which needs to be turned on, now this ITK prefix comes from the named passed<br>
>> to itk_module. Looked at the checked in remotes, it appears that many of<br>
>> them are not consisting the the name of the remote and the name of the<br>
>> module with regards to the ITK prefix.<br>
>><br>
>> What do you think should be done to make this consistent?<br>
>> Should external remote modules have the ITK prefix or just internal ITK<br>
>> modules?<br>
>><br>
>> Perhaps when a module is downloaded or updated we should verify that the<br>
>> name reported in itk_fetch_module matches that in itk_module, and produce an<br>
>> error if not?<br>
>><br>
>> Thanks,<br>
>> Brad<br>
>><br>
>><br>
>><br>
>><br>
>><br>
>> _______________________________________________<br>
>> Powered by <a href="http://www.kitware.com" target="_blank">www.kitware.com</a><br>
>><br>
>> Visit other Kitware open-source projects at<br>
>> <a href="http://www.kitware.com/opensource/opensource.html" target="_blank">http://www.kitware.com/opensource/opensource.html</a><br>
>><br>
>> Kitware offers ITK Training Courses, for more information visit:<br>
>> <a href="http://kitware.com/products/protraining.php" target="_blank">http://kitware.com/products/protraining.php</a><br>
>><br>
>> Please keep messages on-topic and check the ITK FAQ at:<br>
>> <a href="http://www.itk.org/Wiki/ITK_FAQ" target="_blank">http://www.itk.org/Wiki/ITK_FAQ</a><br>
>><br>
>> Follow this link to subscribe/unsubscribe:<br>
>> <a href="http://www.itk.org/mailman/listinfo/insight-developers" target="_blank">http://www.itk.org/mailman/listinfo/insight-developers</a><br>
>><br>
><br>
><br>
><br>
> --<br>
> Unpaid intern in BillsBasement at noware dot com<br>
_______________________________________________<br>
Powered by <a href="http://www.kitware.com" target="_blank">www.kitware.com</a><br>
<br>
Visit other Kitware open-source projects at<br>
<a href="http://www.kitware.com/opensource/opensource.html" target="_blank">http://www.kitware.com/opensource/opensource.html</a><br>
<br>
Kitware offers ITK Training Courses, for more information visit:<br>
<a href="http://kitware.com/products/protraining.php" target="_blank">http://kitware.com/products/protraining.php</a><br>
<br>
Please keep messages on-topic and check the ITK FAQ at:<br>
<a href="http://www.itk.org/Wiki/ITK_FAQ" target="_blank">http://www.itk.org/Wiki/ITK_FAQ</a><br>
<br>
Follow this link to subscribe/unsubscribe:<br>
<a href="http://www.itk.org/mailman/listinfo/insight-developers" target="_blank">http://www.itk.org/mailman/listinfo/insight-developers</a><br>
</div></div></blockquote></div><br><br clear="all"><div><br></div>-- <br><div><br></div><div><br></div>---------------------------------------------<br><b>Xiaoxiao Liu</b>, Ph.D.<div><div><div><font face="arial, sans-serif"><span style="border-collapse:collapse">R & D Engineer</span></font></div>
<div><div><a href="http://www.kitware.com/" target="_blank">Kitware Inc</a>.</div></div><div><span style="border-collapse:collapse;font-family:arial,sans-serif;font-size:13px">Clifton Park, NY</span><div><div>Phone: (518) 881-4924 or <span style="border-collapse:collapse;color:rgb(136,136,136);font-family:arial,sans-serif;font-size:13px">(518) 371-3971 x124</span></div>
<div><font face="Verdana, Arial, Helvetica, sans-serif"><span style="line-height:31px;font-size:x-small"><br></span></font></div></div></div></div></div>
</div>