Difference between revisions of "Computational Fluid Dynamics"

From KitwarePublic
Jump to navigationJump to search
Line 14: Line 14:


[[Image:cfd_slices2.png|1000px]]
[[Image:cfd_slices2.png|1000px]]


==Stream Tracers - lines and tubes==
==Stream Tracers - lines and tubes==
*'''File → Open → Examples → disk_out_ref.exo.'''.  On the '''Properties''' tab, click '''Apply'''.
*'''File → Open → Examples → disk_out_ref.exo.'''.  On the '''Properties''' tab, click '''Apply'''.
*'''+X'''
*'''Filters → Common → Stream Tracer'''.  '''v'''.  Seed Type: '''Point Cloud'''.  Uncheck '''Show Sphere'''.  '''Apply'''.   
*'''Filters → Common → Stream Tracer'''.  '''v'''.  Seed Type: '''Point Cloud'''.  Uncheck '''Show Sphere'''.  '''Apply'''.   
*Color by: '''v'''.
*Color by: '''v'''.
Line 30: Line 32:
*Color by: '''temp'''.
*Color by: '''temp'''.
*'''View → Color Map Editor → Presets''' (the little envelope with a heart)''' → Black Body Radiation'''.
*'''View → Color Map Editor → Presets''' (the little envelope with a heart)''' → Black Body Radiation'''.
*'''Reset'''


[[Image:cfd_streamtracer1.png|1000px]]


picture goes here





Revision as of 23:17, 12 November 2021

Visualizing Computational Fluid Dynamics

This tutorial shows common visualization techniques for cfd datasets. We will be using the dataset disk_out_ref.exo, found in Paraview under File/ Open/ Examples. It has a vector field in it called V.

Slices

  • File → Open → Examples → disk_out_ref.exo.. On the Properties tab, click Apply.
  • +X
  • Filters → Common → Slice. Apply. Unselect the Show Plane.
  • Color by: v.
  • In the pipeline browser, select disk_out_ref.exo
  • Filters → Common → Slice. Y Normal. Apply. Unselect the Show Plane.
  • Color by: pres.
  • View → Color Map Editor → Presets (the little envelope with a heart) → Turbo.
  • With the mouse, rotate the slices around so you can see both surfaces.

Cfd slices2.png


Stream Tracers - lines and tubes

  • File → Open → Examples → disk_out_ref.exo.. On the Properties tab, click Apply.
  • +X
  • Filters → Common → Stream Tracer. v. Seed Type: Point Cloud. Uncheck Show Sphere. Apply.
  • Color by: v.

Lines don't color as nicely as surfaces. Lets add a tube filter around each streamline.

  • Filters → Search. Type Tube. Apply.

Now, we want to know which directions the particles are moving. We will use a glyph filter. Note we place the glyph filter on the streamline, not the tube.

  • Select StreamTracer in the Pipeline Browser.
  • Filters → Common → Glyph. Glyph Type: Cone. Orientation Array: v. Scale Array: v . Very Important - Scale Factor select the recycle button to the right. Apply.
  • Color by: temp.
  • View → Color Map Editor → Presets (the little envelope with a heart) → Black Body Radiation.
  • Reset


Cfd streamtracer1.png


Glyphs perpendicular to a slice

Flow in a fluid

Gradient and Curl

Probing a fluid

Volume Rendering