[Insight-developers] Unary Filters family

Luis Ibanez ibanez@cs.unc.edu
Mon, 19 Feb 2001 18:59:55 -0500


Hi,

We are preparing a family of Unary filters along with a
parallel family of ImageAdaptors.   The will basically
do trivial pixel-wise operations like:

Sin
Cos
Tan
Log
Exp

The ImageAdaptor versions will do the conversion
each time the pixel is accessed, so they are convenient
for sparse access. The Filter version will just pass the
whole image through the funcion.

The proposed names could be:

itkSinImageFilter
itkCosImageFilter
itkTanImageFilter
itkLogImageFilter...

itkSinImageAdaptor
itkCosImageAdaptor
itkTanImageAdaptor

...

Would that fit in the naming conventions ?


Thanks

Luis

--
______________________________________________________________________

Luis Ibanez
Research Assistant Professor - Division of Neurosurgery
University of North Carolina at Chapel Hill
CB# 7060, Chapel Hill, NC 27599
email : ibanez@cs.unc.edu       home  : http://www.cs.unc.edu/~ibanez
phone : (919)-843-9961          fax   : (919)-966-6627
______________________________________________________________________