[Insight-developers] Renaming Image Iterators

Luis Ibanez ibanez@choroid.cs.unc.edu
Fri, 11 May 2001 14:27:36 -0400 (EDT)


Hi,

As suggested today in the TCon,

In order to reduce confusion between
different iterators styles, like
STL, itkContainers and itkImages,
we are looking for new names
for itkImageIterators:

Here are some of the proposed names:

- Walker
- Runner

So them could look like:

 itk::ImageRegionWalker<>
 itk::ImageLinearWalker<>
 itk::ImageSliceWalker<>
 ...
 itk::ImageRandomWalker<>



They will use the API:

 WalkerType wi(myImage,myRegion);

 wi.Begin();
 while( !wi.IsAtEnd() )
 {
   *wi = 5;
   ++wi;
 }


BTW given that the IsAtEnd() method is always
negated on the while... could be renamed to
rather return:

        wi.IsNotAtEnd()   ?
 or     wi.StillToWalk()  ?





any suggestions ?




Luis