[Insight-developers] method names in Transforms

Luis Ibanez ibanez@choroid.cs.unc.edu
Wed, 30 May 2001 10:29:18 -0400 (EDT)


Hi

The methods in transform were renamed from:

  Transform( itk::Point )
  Transform( itk::Vector )
  Transform( itk::CovariantVector )
  Transform( vnl_vector )

As:

  TransformPoint( itk::Point )
  TransformVector( itk::Vector )
  TransformVector( itk::CovariantVector )
  TransformVector( vnl_vector )


But the BackTransform() methods were left
unchanged.

Do we want to use as a Style rule to add the
parameter of methods as part of the name  ?

Should them be ?:

  TransformCovariantVector( itk::CovariantVector )
  TransformVnlVector( vnl_vector )


Any preferences ?



---

BTW in order to add the Rigid3DPerspective transform,
(that is used in 3D/2D registration) the transform API
has to be modified because the input point and the output
point don't have the same dimension any more. So, types
will be now: InputPointType, OutputPointType... and so on.

Does anybody see conflicts with this modification ?


Luis