[Insight-developers] ImageIO Streaming

Bill Lorensen bill.lorensen at gmail.com
Mon Jul 2 19:35:18 EDT 2007


I assume Determining will be spelled correctly and not Determing?

Bill

On 7/2/07, Hans Johnson <hans-johnson at uiowa.edu> wrote:
>
> Luis,
>
> I was thinking about this also.  I would think that the answer is
> "Probably".  If you write a sub-region to a new file, I think that you
> will
> actually need to write a "LargestPossibleRegion" to make a valid file
> output.  The area outside the specified region should be all zeros (or
> some
> specified background value).  If you were writing to an existing file,
> then
> only the voxels in the specified region should be modified in the
> resulting
> output file.
>
> This problem is much harder, and less likely to be needed at the moment.
> I'd like to focus on just the streaming read problems for the moment.
>
> ====
> It is, however, critical that the function names are changed now so that
> we
> can maintain backwards compatibility once the file writing mechanisms are
> ready to be implemented.
>
>
> Hans
>
>
>
> --
> Hans J. Johnson, Ph.D.
> Hans-johnson at uiowa.edu
>
> 278 GH
> The University of Iowa
> Iowa City, IA 52241
> (319) 353 8587
>
>
> > From: Luis Ibanez <luis.ibanez at kitware.com>
> > Date: Mon, 02 Jul 2007 16:34:29 -0400
> > To: Hans Johnson <hans-johnson at uiowa.edu>
> > Cc: Kent Williams <norman-k-williams at uiowa.edu>, ITK
> > <insight-developers at itk.org>
> > Subject: Re: [Insight-developers] ImageIO Streaming
> >
> >
> > Hi Hans,
> >
> > Thanks for the quick answer.
> >
> > I'll proceed to remove the CanStreamRead() method from the API.
> >
> > On a second note, I would imagine that for writing we need a twin
> > method of the DetermingStreamableRegionFromRequestedRegion().
> >
> > That means that we probably should rename this method as:
> >
> >    DetermingStreamableReadRegionFromRequestedRegion()
> >                       ^^^^
> >
> > or something along those lines.
> >
> > The twin method:
> >
> >    DetermingStreamableWriteRegionFromRequestedRegion()
> >                       ^^^^^
> >
> > Will define the smallest image region that the ImageIO object
> > can write when requested to write a "RequestedRegion".  E.g.
> > it will enlarge the output region to the quantum units of the
> > fileformat.
> >
> >
> >   Will this apply to "Nifi"  ?
> >
> >
> >    Thanks
> >
> >
> >
> >      Luis
> >
> >
> > ---------------------
> > Hans Johnson wrote:
> >> Luis,
> >>
> >> I fully support removing the CanStreamRead method.
> >> Hans
> >>
>
> _______________________________________________
> Insight-developers mailing list
> Insight-developers at itk.org
> http://www.itk.org/mailman/listinfo/insight-developers
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.itk.org/mailman/private/insight-developers/attachments/20070702/9c4eee12/attachment.html


More information about the Insight-developers mailing list