[Insight-users] itkMatrix typedefs and static consts

Luis Ibanez luis . ibanez at kitware . com
Tue, 25 Nov 2003 15:48:04 -0500


Hi Jeffrey,

The typedefs and the static const were added to the Matrix.

http://www . itk . org/cgi-bin/cvsweb . cgi/Insight/Code/Common/itkMatrix . h . diff?r1=1 . 13&r2=1 . 14&cvsroot=Insight&sortby=date

Please let us know if you find any problems,

Thanks


   Luis

-------------------------

Jeffrey Duda wrote:


> Luis,
> Those names are fine, although I'm assuming you meant ColumnDimensions 
> as opposed to ColumDimensions.  Also, I noticed that itkVector has both:
> 
> typedef T ValueType;
> typedef T ComponentType;
> 
> Maybe this is due to a similar naming issue, but it may be worth using 
> both in itkMatrix to remain consistent.  Thanks for the quick response. 
>  I'm working on some filters for vectors and matrix images and this will 
> make some things a bit easier.
> 
> thanks again,
> -jeff
> 
> Luis Ibanez wrote:
> 
>>
>> Hi Jeffrey,
>>
>>
>> There is no particular reason for not creating the
>> typedef for component type in the matrix, and the
>> static dimensions of row and columns.  It is simply
>> that we haven't need them so far.
>>
>> We could perfectly add something like
>>
>>
>>>   typedef T ValueType;
>>>
>>>   itkStaticConstMacro(RowDimensions,   unsigned int, NRows);
>>
>>
>>  >   itkStaticConstMacro(ColumDimensions, unsigned int, NColumns);
>>
>>>
>>
>> It will just be a matter of getting concensus on the
>> naming.
>>
>> Would you find those above to be appropriate names ?
>>
>> This is one of those things that is quite easy to add to a class,
>> but it will be quit hard to get ride of it later. So, giving some
>> thought to the naming may be worth.
>>
>>
>> Please let us know what you think,
>>
>>
>> Thanks
>>
>>
>>   Luis
>>
>>
>>
>> ------------------------
>> Jeffrey Duda wrote:
>>
>>> itkVector includes a typedef for ValueType and a static const for 
>>> Dimension, but itkMatrix does not include either of these.  The 
>>> ValueType can be obtained through the InternalMatrixType, but is 
>>> there a way to get the Row and Column dimensions?  Is there a 
>>> particular reason that the matrix dimensions aren't included as 
>>> static const's in itkMatrix?
>>>
>>> -- jeff duda
>>> _________________________________
>>> http://www . seas . upenn . edu/~jtduda
>>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>>
>>> _______________________________________________
>>> Insight-users mailing list
>>> Insight-users at itk . org
>>> http://www . itk . org/mailman/listinfo/insight-users
>>>
>>
>>
> 
> 
>